数学笔记:逆元
逆元 一整数a …
May all the beauty be blessed.
题目地址:洛谷:【P3338】[ZJOI2014]力 – 洛谷、BZOJ:Problem 3527. — [Zjoi2014]力
给出n个数q_i,给出F_j的定义如下:
F_j = \sum_{i < j} \frac{q_iq_j}{(i-j)^2} - \sum_{i > j} \frac{q_iq_j}{(i-j)^2}
令E_i = \frac{F_i}{q_i},求E_i。
输入格式:
第一行一个整数n。
接下来n行每行输入一个数,第i行表示qi。
输出格式:
n行,第i行输出Ei。
与标准答案误差不超过1e-2即可。
输入样例#1:
5 4006373.885184 15375036.435759 1717456.469144 8514941.004912 1410681.345880
输出样例#1:
-16838672.693 3439.793 7509018.566 4595686.886 10903040.872
对于30%的数据,n≤1000。
对于50%的数据,n≤60000。
对于100%的数据,n≤100000,0<qi<1000000000。
根据F的定义我们展开E的定义,如下
E_i = \sum_{j=1}^{i-1} \frac{q_j}{(i-j)^2} - \sum_{j=i+1}^{n} \frac{q_j}{(j-i)^2}
如果我们让a_i = q_i, b_i = \frac{1}{i^2}, b_0 = 0,代换掉再观察E的定义
E_i = \sum_{j=0}^{i-1} a_jb_{i-j} - \sum_{j=i+1}^{n} a_jb_{j-i}
第一项的求和实际上已经是卷积的形式了,但是后面这一项不是。我们考虑给这一项改一改
E_i = \sum_{j=0}^{i-1} a_jb_{i-j} - \sum_{j=0}^{n-i-1} a_{i+j}b_{j}
后面这一项好像还不是卷积呀,那如果我们令c_{n-i-j-1}=a_{i+j}(相当于把a数组翻过来存),带换掉?
E_i = \sum_{j=0}^{i-1} a_jb_{i-j} - \sum_{j=0}^{n-i-1} c_{n-i-j-1}b_{j}
好像可以卷积了!为了便于理解,我们换一种形式
A_i = \sum_{j=0}^{n-i-1} c_{n-i-j-1}b_{j} \Rightarrow A_{n-i-1} = \sum_{j=0}^{i} c_{i-j}b_{j}
这样我们看后面一项就是个卷积的形式。
// Code by KSkun, 2018/3
#include <cstdio>
#include <cmath>
#include <cstring>
#include <algorithm>
const int MAXN = 1 << 20;
const double PI = std::acos(-1);
struct Complex {
double real, imag;
Complex(double real = 0, double imag = 0) : real(real), imag(imag) {}
inline Complex operator+(const Complex &rhs) const {
return Complex(real + rhs.real, imag + rhs.imag);
}
inline Complex operator-(const Complex &rhs) const {
return Complex(real - rhs.real, imag - rhs.imag);
}
inline Complex operator*(const Complex &rhs) const {
return Complex(real * rhs.real - imag * rhs.imag, real * rhs.imag + imag * rhs.real);
}
inline Complex& operator*=(const Complex &rhs) {
return *this = *this * rhs;
}
};
int n, m, len, rev[MAXN];
Complex a[MAXN], b[MAXN];
double s[MAXN], ans[MAXN];
inline void fft(Complex *arr, int f) {
for(int i = 0; i < n; i++) {
if(i < rev[i]) std::swap(arr[i], arr[rev[i]]);
}
for(int i = 1; i < n; i <<= 1) {
Complex wn(std::cos(PI / i), f * std::sin(PI / i));
for(int j = 0; j < n; j += i << 1) {
Complex w(1, 0);
for(int k = 0; k < i; k++) {
Complex x = arr[j + k], y = w * arr[j + k + i];
arr[j + k] = x + y;
arr[j + k + i] = x - y;
w *= wn;
}
}
}
}
int N;
int main() {
scanf("%d", &N); n = N - 1;
for(int i = 0; i < N; i++) {
scanf("%lf", &s[i]);
}
m = n << 1;
for(n = 1; n <= m; n <<= 1) len++;
for(int i = 0; i < n; i++) {
rev[i] = (rev[i >> 1] >> 1) | ((i & 1) << (len - 1));
}
for(int i = 0; i < N; i++) {
a[i].real = s[i];
if(i) b[i].real = 1 / double(i) / double(i);
}
fft(a, 1);
fft(b, 1);
for(int i = 0; i <= n; i++) {
a[i] *= b[i];
}
fft(a, -1);
for(int i = 0; i < N; i++) {
ans[i] = a[i].real / double(n);
}
memset(a, 0, sizeof(a));
for(int i = 0; i < N; i++) {
a[i].real = s[N - i - 1];
}
fft(a, 1);
for(int i = 0; i <= n; i++) {
a[i] *= b[i];
}
fft(a, -1);
for(int i = 0; i < N; i++) {
ans[i] -= a[N - i - 1].real / double(n);
}
for(int i = 0; i < N; i++) {
printf("%.3lf\n", ans[i]);
}
return 0;
}
题目地址:洛谷:【P1919】【模板】A*B Problem升级版(FFT快速傅里叶) – 洛谷、BZOJ:Problem 2179. — FFT快速傅立叶
写这题只是为了证明我今天写了两个题。无视即可。
给出两个n位10进制整数x和y,你需要计算x*y。
输入格式:
第一行一个正整数n。 第二行描述一个位数为n的正整数x。 第三行描述一个位数为n的正整数y。
输出格式:
输出一行,即x*y的结果。(注意判断前导0)
输入样例#1:
1 3 4
输出样例#1:
12
数据范围:n<=60000
实际上乘法是在对每一位做卷积。倒序读进去,FFT一下,倒序输出即可。
// Code by KSkun, 2018/3
#include <cstdio>
#include <cmath>
#include <algorithm>
typedef long long LL;
inline char fgc() {
static char buf[100000], *p1 = buf, *p2 = buf;
return p1 == p2 && (p2 = (p1 = buf) + fread(buf, 1, 100000, stdin), p1 == p2) ? EOF
: *p1++;
}
inline LL readint() {
register LL res = 0, neg = 1;
char c = fgc();
while(c < '0' || c > '9') {
if(c == '-') neg = -1;
c = fgc();
}
while(c >= '0' && c <= '9') {
res = res * 10 + c - '0';
c = fgc();
}
return res * neg;
}
inline int readsingle() {
char c = fgc();
while(c < '0' || c > '9') c = fgc();
return c - '0';
}
const int MAXN = 1 << 17;
const double PI = acos(-1);
struct Complex {
double real, imag;
Complex(double real = 0, double imag = 0) : real(real), imag(imag) {}
inline Complex operator+(const Complex &rhs) const {
return Complex(real + rhs.real, imag + rhs.imag);
}
inline Complex operator-(const Complex &rhs) const {
return Complex(real - rhs.real, imag - rhs.imag);
}
inline Complex operator*(const Complex &rhs) const {
return Complex(real * rhs.real - imag * rhs.imag, real * rhs.imag + imag * rhs.real);
}
inline Complex& operator*=(const Complex &rhs) {
Complex old = *this;
real = old.real * rhs.real - old.imag * rhs.imag;
imag = old.real * rhs.imag + old.imag * rhs.real;
return *this;
}
};
int n, m, len, rev[MAXN], c[MAXN];
Complex a[MAXN], b[MAXN];
inline void fft(Complex *arr, int f) {
for(int i = 0; i < n; i++) {
if(i < rev[i]) std::swap(arr[i], arr[rev[i]]);
}
for(int i = 1; i < n; i <<= 1) {
Complex wn(cos(PI / i), f * sin(PI / i));
for(int j = 0; j < n; j += i << 1) {
Complex w(1, 0);
for(int k = 0; k < i; k++) {
Complex x = arr[j + k], y = w * arr[j + k + i];
arr[j + k] = x + y;
arr[j + k + i] = x - y;
w *= wn;
}
}
}
}
int main() {
n = readint() - 1;
for(int i = 0; i <= n; i++) {
a[n - i].real = readsingle();
}
for(int i = 0; i <= n; i++) {
b[n - i].real = readsingle();
}
m = n << 1;
for(n = 1; n <= m; n <<= 1) len++;
for(int i = 0; i < n; i++) {
rev[i] = (rev[i >> 1] >> 1) | ((i & 1) << (len - 1));
}
fft(a, 1);
fft(b, 1);
for(int i = 0; i <= n; i++) {
a[i] *= b[i];
}
fft(a, -1);
for(int i = 0; i <= m; i++) {
c[i] = int(a[i].real / n + 0.5);
}
for(int i = 0; i <= m; i++) {
if(c[i] >= 10) {
c[i + 1] += c[i] / 10;
c[i] %= 10;
if(i == m) m++;
}
}
bool flag = true;
for(int i = m; i >= 0; i--) {
if(flag && c[i]) flag = false;
if(!flag) printf("%d", c[i]);
}
return 0;
}
虚数单位i定义为二次方程式x^2+1=0的两个解答中的一个解答。也就是说,虚数单位可以表达为i^2 = -1或i = \sqrt{-1}。
复数为实数的延伸,它使任一多项式方程式都有根。
复数都可表达为x+yi,其中x及y皆为实数,分别称为复数的实部和虚部。
设有非零复数z \in \mathbb{C} \backslash \{ 0 \},记作z = x + yi,其中的x和y为实数,那么复数z的幅角\varphi指的是使下列等式:
z = x + yi = \sqrt{x^2 + y^2} (\cos \varphi + i \sin \varphi)
成立的任何实数\varphi。
几何意义参见:幅角 – 维基百科,自由的百科全书
只有非零复数有幅角。
对任意实数x,都存在e^{ix} = \cos x + i \sin x = \mathrm{cis} \ x。
还可以推导出\sin x = \frac{e^{ix} - e^{-ix}}{2i}及\cos x = \frac{e^{ix} + e^{-ix}}{2}。
\mathrm{cis} \ \theta = \frac{z}{|z|} = \cos \theta + i \sin \theta
其中,z是幅角为\theta的复数。
对任意复数x和整数n,下列性质成立:
(\cos x + i \sin x)^n = \cos nx + i \sin nx
或者说
\mathrm{cis}^n \ x = \mathrm{cis} \ nx
n次单位根是n次幂为1的复数,它们在复平面的单位圆上均匀分布,其中一个顶点是1。
单位的n次根有n个,分别为
\omega_n^k = e^{\frac{2 \pi ki}{n}} \ (k = 0, 1, 2, \ldots, n-1)
定义\omega_n = e^{\frac{2 \pi i}{n}}为主n次单位根,其他单位根为它的整数次幂。
对任意整数n \geq 0, k \geq 0, d \geq 0,有:
\omega_{dn}^{dk} = \omega_n^k
证明:由定义
如果n > 0为偶数,那么n个n次单位根的平方的集合就是\frac{n}{2}个\frac{n}{2}次单位根的集合。
证明:实际上就是在说对任意非负整数k,有 (\omega_n^k)^2 = \omega_{\frac{n}{2}}^k 。由消去引理
对于任意整数n \geq 1与不能被n整除的非负整数k,有
\sum_{j=0}^{n-1}(\omega_n^k)^j = 0
证明:由几何级数的求和公式
\sum_{k=0}^n x^k = \frac{x^{n+1} - 1}{x - 1}